# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"title\":\s*\"([^\"]*\bSword\b[^\"]*)\""
test_str = ("\n"
" {\n"
" \"store\": {\n"
" \"book\": [\n"
" {\n"
" \"category\": \"reference\",\n"
" \"author\": \"Nigel Rees\",\n"
" \"title\": \"Sayings of the Century\",\n"
" \"price\": 8.95\n"
" },\n"
" {\n"
" \"category\": \"fiction\",\n"
" \"author\": \"Evelyn Waugh\",\n"
" \"title\": \"Sword of Honour\",\n"
" \"price\": 12.99\n"
" },\n"
" {\n"
" \"category\": \"fiction\",\n"
" \"author\": \"Herman Melville\",\n"
" \"title\": \"Moby Dick\",\n"
" \"isbn\": \"0-553-21311-3\",\n"
" \"price\": 8.99\n"
" },\n"
" {\n"
" \"category\": \"fiction\",\n"
" \"author\": \"J. R. R. Tolkien\",\n"
" \"title\": \"The Lord of the Rings\",\n"
" \"isbn\": \"0-395-19395-8\",\n"
" \"price\": 22.99\n"
" }\n"
" ],\n"
" \"bicycle\": {\n"
" \"color\": \"red\",\n"
" \"price\": 19.95\n"
" }\n"
" },\n"
" \"expensive\": 10\n"
" }\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.