#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:met .*?(?=(?:(?:\d+\/)?\d+\w ?)))|(?:(?:\d+\/)?\d+\w ?)|(?:\d+ ?in ?\d+)"
Local $sString = "1/4w 1/4s 1/4w 1/4d 3 in 1 1% led met interne weerstand 1/4w"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")