$re = '/(?:met .*?(?=(?:(?:\d+\/)?\d+\w ?)))|(?:(?:\d+\/)?\d+\w ?)|(?:\d+ ?in ?\d+)/i';
$str = '1/4w 1/4s 1/4w 1/4d 3 in 1 1% led met interne weerstand 1/4w';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);