using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)?\s*\bcite\b\s*(\w+)?";
string input = @"cite any cases or other legal materials that cite the arbitrator should read before the hearing attachments cite";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}