re = /(\w+)?\s*\bcite\b\s*(\w+)?/
str = 'cite any cases or other legal materials that cite the arbitrator should read before the hearing attachments cite'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end