import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((AND|OR|NOT)( ))?([a-z_A-Z0-9]*):(\"\\w+.*\"|\\w+(:?\\w+))";
final String string = "homo sapiens AND curationstatus:\"Manually curated\" AND modellingapproach:\"Ordinary differential equation model\"\n\n"
+ "test AND UNIPROT:23456 AND metabolism AND heart AND TAXONOMY:40674 AND curation:\"Non curated\" AND GO:GO:34212 AND publication:23444 AND modellingapproach:\"logical model\" AND cancer\n\n"
+ "modelformat:\"SBML\" AND modelformat:\"SBML\" AND modellingapproach:\"Ordinary differential equation model\" AND TAXONOMY:9606\n\n"
+ "*:* AND modelformat:\"SBML\" AND modellingapproach:\"Ordinary differential equation model\" AND TAXONOMY:9606 AND TAXONOMY:10090\n\n"
+ "*:* AND disease:\"Lung Adenocarcinoma\" AND cancer AND tumor";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}