import Foundation
let pattern = #"((AND|OR|NOT)( ))?([a-z_A-Z0-9]*):("\w+.*"|\w+(:?\w+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
homo sapiens AND curationstatus:"Manually curated" AND modellingapproach:"Ordinary differential equation model"
test AND UNIPROT:23456 AND metabolism AND heart AND TAXONOMY:40674 AND curation:"Non curated" AND GO:GO:34212 AND publication:23444 AND modellingapproach:"logical model" AND cancer
modelformat:"SBML" AND modelformat:"SBML" AND modellingapproach:"Ordinary differential equation model" AND TAXONOMY:9606
*:* AND modelformat:"SBML" AND modellingapproach:"Ordinary differential equation model" AND TAXONOMY:9606 AND TAXONOMY:10090
*:* AND disease:"Lung Adenocarcinoma" AND cancer AND tumor
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)