# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?x)^\n"
r" (?P<remote_host>\S+) \s+ # host %h\n"
r" \S+ \s+ # indent %l (unused)\n"
r" (?P<remote_user>\S+) \s+ # user %u\n"
r" \[(?P<time_received>.*?)\] \s+ # time %t\n"
r" \"(?P<request>.*?)\" \s+ # request \"%r\"\n"
r" (?P<status>[0-9]+) \s+ # status %>s\n"
r" (?P<response_bytes_clf>\S+) (?:\s+ # size %b (careful, can be '-')\n"
r" \"(?P<referrer>[^\"?\s]*[^\"]*)\" \s+ # referrer \"%{Referer}i\"\n"
r" \"(?P<user_agent>.*? )\" (?:\s+ # user agent \"%{User-agent}i\"\n"
r" \"[^\"]*\" )?)? # optional argument (unused)\n"
r"$")
test_str = ("190.2.7.178 - - [21/Dec/2011:05:47:03 +0000] \"GET /gnu3/index.php?doc=../../../../../../../proc/self/environ%00 HTTP/1.1\" 404 273 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:04 +0000] \"GET /gnu/index.php?doc=../../../../../../../proc/self/environ%00 HTTP/1.1\" 404 271 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:04 +0000] \"GET /phpgwapi/setup/tables_update.inc.php?appdir=../../../../../../../proc/self/environ%00 HTTP/1.1\" 404 286 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:05 +0000] \"GET /forum/install.php?phpbb_root_dir=../../../../../../../proc/self/environ%00 HTTP/1.1\" 404 274 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:06 +0000] \"GET /includes/calendar.php?phpc_root_path=../../../../../../../proc/self/environ%00 HTTP/1.1\" 404 275 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:06 +0000] \"GET /includes/setup.php?phpc_root_path=../../../../../../../proc/self/environ%00 HTTP/1.1\" 404 273 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:07 +0000] \"GET /inc/authform.inc.php?path_pre=../../../../../../../proc/self/environ%00 HTTP/1.1\" 404 275 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:07 +0000] \"GET /include/authform.inc.php?path_pre=../../../../../../../proc/self/environ%00 HTTP/1.1\" 404 278 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:08 +0000] \"GET /index.php?nic=../../../../../../../proc/self/environ%00 HTTP/1.1\" 200 4399 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n"
"190.2.7.178 - - [21/Dec/2011:05:47:11 +0000] \"GET /index.php?sec=../../../../../../../proc/self/environ%00 HTTP/1.1\" 200 4399 \"-\" \"<?php system(\\\"id\\\"); ?>\"\n\n\n\n"
"123.125.71.79 - - [28/Apr/2012:08:12:57 +0100] \"GET /robots.txt HTTP/1.1\" 404 268 \"-\" \"Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)\"\n"
"157.56.95.126 - - [28/Apr/2012:10:23:02 +0100] \"GET /robots.txt HTTP/1.1\" 404 268 \"-\" \"msnbot/2.0b (+http://search.msn.com/msnbot.htm)\"\n"
"157.56.95.126 - - [28/Apr/2012:10:23:02 +0100] \"GET / HTTP/1.1\" 200 4399 \"-\" \"msnbot/2.0b (+http://search.msn.com/msnbot.htm)\"\n"
"110.75.173.193 - - [28/Apr/2012:11:57:26 +0100] \"GET / HTTP/1.1\" 200 4399 \"-\" \"Yahoo! Slurp China\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.