using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^)]*\)(*SKIP)(*F)|\|";
string input = @"999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}