const regex = /\([^)]*\)(*SKIP)(*F)|\|/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([^)]*\\)(*SKIP)(*F)|\\|', 'g')
const str = `999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}