use strict;
my $str = '999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111';
my $regex = qr/\([^)]*\)(*SKIP)(*F)|\|/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}