// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\([^)]*\)(*SKIP)(*F)|\|").unwrap();
let string = "999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}