import Foundation
let pattern = #"\([^)]*\)(*SKIP)(*F)|\|"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)