re = /<a\b(?=(?>[^>]*rel\s*=\s*[\"\']([^\"\']+))?)[^>]*href=\s*[\"\']\s*\K[^\"\']+/
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do
eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi
ut aliquip ex ea commodo consequat. <a href="http://example.com" rel="nofollow">Duis</a>
nirure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat
nulla pariatur. Excepteur sint <a href="http://example2.com" rel="nofollow">Duis</a> occaecat cupidatat non proident, sunt in culpa qui
officia deserunt mollit anim id est laborum.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end