using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Loadcase -- \d+\s+(.+)\s{6}";
string input = @"Loadcase -- 1 Dead + Roof Live Dur Factors: 1.15 1.15
Domain Type ------------Name------------ Dir plf-beg plf-end -x-beg-- -x-end-- -y-beg-- -y-end--
Top Dead TCDL Vert 14.00 14.00 -2-00-00 11-00-00
Top Dead TCDL Vert 14.00 14.00 11-00-00 24-00-00
Bottom Dead BCDL Vert 20.00 20.00 0 22-00-00
Attic_BC Dead RoomDL_BC Vert 20.00 20.00 3-06-08 18-02-12
Attic_TC Dead RoomDL_TC Vert 10.00 10.00 3-09-04 18-02-12
Top RoofLive TCLL Vert 60.00 60.00 -2-00-00 11-00-00
Top RoofLive TCLL Vert 60.00 60.00 11-00-00 24-00-00
Domain Type ------------Name------------ Dir Lbs -x-loc-- -y-loc-- EQ plf EQ width
Bottom Dead SidewallDL Vert 49 3-05-03 07-05 24.5 24.0
Bottom Dead SidewallDL Vert 49 18-04-01 07-03 24.5 24.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}