package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(\d+)(.*)`)
var str = `This order was placed for QT3000! OK?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}