$re = '/^.*(?!you).*\?$/m';
$str = 'cowyouare
elephantiam
mosquitoyouseemtobe
mokeyyoumight
tmyou
UVM_INFO @ 2825.0ns: [ig_scb] PARITY_ERROR detected
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);