package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\")?(?:\w+(?:\.|\_|\<)?)+\w+(?:\")?@(?:\w+\.)+\w{2,}(?:\>)?$`)
var str = `john@something.com
john.doe_@yahoo.com
"john.doe"@gmail.com
John_Doe_<johnDoe@something.net>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}