# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(th|td)>.*?<\\/\1>(*SKIP)(*F)|\n//gs;t' <<< "<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td>cell
content</td><td>cell 2</td></tr>
</table>"