import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(th|td)>.*?<\\/\\1>(*SKIP)(*F)|\\n";
final String string = "<table>\n"
+ "<tr><th>HEader 1</th><th> header \n"
+ "2</th>\n"
+ "</tr>\n"
+ "<tr><td>cell \n"
+ "content</td><td>cell 2</td></tr>\n"
+ "</table>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}