# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)<(t[hd])[^>]*?>.*?<\\/\1>(*SKIP)(*FAIL)|\n//g;t' <<< "<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td width=\"100\"><b>cell
content</b></td><td>cell 2</td></tr>
</table>"