import Foundation
let pattern = #"(?s)<(t[hd])[^>]*?>.*?<\/\1>(*SKIP)(*FAIL)|\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td width="100"><b>cell
content</b></td><td>cell 2</td></tr>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)