package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:10|127|172\.(?:1[6-9]|2[0-9]|3[01])|192\.168)\..*`)
var str = `1.2.3.4
192.168.10.20
10.20.30.40
172.10.20.30
172.17.100.200
127.0.0.1
100.200.300.400
1.192.168.200
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}