import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:10|127|172\\.(?:1[6-9]|2[0-9]|3[01])|192\\.168)\\..*";
final String string = "1.2.3.4\n"
+ "192.168.10.20\n"
+ "10.20.30.40\n"
+ "172.10.20.30\n"
+ "172.17.100.200\n"
+ "127.0.0.1\n"
+ "100.200.300.400\n"
+ "1.192.168.200\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}