# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:10|127|172\.(?:1[6-9]|2[0-9]|3[01])|192\.168)\..*"
test_str = ("1.2.3.4\n"
"192.168.10.20\n"
"10.20.30.40\n"
"172.10.20.30\n"
"172.17.100.200\n"
"127.0.0.1\n"
"100.200.300.400\n"
"1.192.168.200\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.