package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?<Message>.*)[\.](?:[\s]id:(?<id>.*)[\.])? Code:(?<Code>.*)[\.]`)
var str = `Failed to send sms. code:5063.
Failed to send sms. id:23. code:5063.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}