re = /(?<Message>.*)[\.](?:[\s]id:(?<id>.*)[\.])? Code:(?<Code>.*)[\.]/im
str = 'Failed to send sms. code:5063.
Failed to send sms. id:23. code:5063.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end