#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?\s?7\s?\(?-?(?# code)[0-9]{3}(?# next 3 digit)\s?\)?-?\s?[0-9]{3}\s?-?(?# next 2 digits)[0-9]{2}\s?-?(?# the last 2 digits)[0-9]{2}"
Local $sString = "79001234567" & @CRLF & _
"7 900 1234567" & @CRLF & _
"7 900 123 45 67" & @CRLF & _
"7-900-123-45-67" & @CRLF & _
"7 900 123-45-67" & @CRLF & _
"7900 123-45-67" & @CRLF & _
"7(900)1234567" & @CRLF & _
"7 (900) 123 45 67" & @CRLF & _
"7 (900) 123-45-67" & @CRLF & _
"+79001234567" & @CRLF & _
"+7 900 123 45 67" & @CRLF & _
"+7 (900) 123-45-67"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")