^start of line
\+?optionally matches the literal + (4310 / 538 / 2B16)
\s?optionally matches any whitespace character
7the literal 7 (5510 / 678 / 3716)
\s?optionally matches any whitespace character
\(?optionally matches the literal ( (4010 / 508 / 2816)
-?optionally matches the literal - (4510 / 558 / 2D16)
Comment: code
{3}matches exactly 3 characters from the set below:
0-9one character from 0 (4810) to 9 (5710)
Comment: next 3 digit
\s?optionally matches any whitespace character
\)?optionally matches the literal ) (4110 / 518 / 2916)
-?optionally matches the literal - (4510 / 558 / 2D16)
\s?optionally matches any whitespace character
{3}matches exactly 3 characters from the set below:
0-9one character from 0 (4810) to 9 (5710)
\s?optionally matches any whitespace character
-?optionally matches the literal - (4510 / 558 / 2D16)
Comment: next 2 digits
{2}matches exactly 2 characters from the set below:
0-9one character from 0 (4810) to 9 (5710)
\s?optionally matches any whitespace character
-?optionally matches the literal - (4510 / 558 / 2D16)
Comment: the last 2 digits
{2}matches exactly 2 characters from the set below:
0-9one character from 0 (4810) to 9 (5710)
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string