using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{1,2}:?(?:[0-9]{2})?)-([0-9]{1,2}:?(?:[0-9]{2})?)\s(AM|PM)";
string input = @"@HOME 8:30-4:15 PM: Full analysis of Concur report (EFF) > Q1 report (Stan 5/6/15) > Sign-in Sheets (127 meetings)
@HUB 2:30-3:30 PM: Planning and meeting with Stanley Braxton
@HUB 9-4 PM, 6-8 PM: Ashfield HCPHUB configuration; (Old) expenses analysis from Stan; Gaining Concur access from Covis (Dawn)
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}