# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{1,2}:?(?:[0-9]{2})?)-([0-9]{1,2}:?(?:[0-9]{2})?)\s(AM|PM)"
test_str = ("@HOME 8:30-4:15 PM: Full analysis of Concur report (EFF) > Q1 report (Stan 5/6/15) > Sign-in Sheets (127 meetings)\n\n"
"@HUB 2:30-3:30 PM: Planning and meeting with Stanley Braxton\n\n"
"@HUB 9-4 PM, 6-8 PM: Ashfield HCPHUB configuration; (Old) expenses analysis from Stan; Gaining Concur access from Covis (Dawn)\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.