$re = '/(var\s|)\s*\w+\s+=\s+require\(\'[\w.\/]*sass[\w.\/]*\'\);*\s*/';
$str = '/** File Head **/
var StyleSheet = require(\'./stylesheet.scss\');var test;
var test2 = require(\'lodash\');
var another = require(\'../../scss/test\');
styleSheet = require(\'stylesheet.scss\'), styleSheet = require(\'stylesheet.sass\')
StyleSheet = require(\'./stylesheet.scss\');var test;
var common = require(\'common.js\');
/** File Foot **/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);