#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\(link\)(.*?)\(\/link\)"
Local $sString = "(link)there is link1(/link), (link)there is link2(/link)"
Local $sSubst = "<a href='$1'>$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)