const regex = /.* \( ((.+),_(.+)) \)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.* \\( ((.+),_(.+)) \\)', 'g')
const str = `24_Horn_Trios,_Op.82_(Reicha,_Anton)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);