re = /.* \( ((.+),_(.+)) \)/x
str = '24_Horn_Trios,_Op.82_(Reicha,_Anton)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result