# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http(:\/\/7\.beta\.org|s?:\/\/((([123]\.alph|[45]\.bet)a\.com)|6\.(alph|bet)a\.org))"
test_str = ("http://1.alpha.com\n"
"http://2.alpha.com\n"
"http://3.alpha.com\n"
"http://4.beta.com\n"
"http://5.beta.com\n"
"http://6.beta.org\n"
"http://7.beta.org\n"
"https://1.alpha.com\n"
"https://2.alpha.com\n"
"https://3.alpha.com\n"
"https://4.beta.com\n"
"https://5.beta.com\n"
"https://6.alpha.org\n\n"
"DO NOT MATCH\n"
"http://2.beta.com\n"
"https://5.alpha.org")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.