#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)([A-zА-я]+[0-9]*(?!\())"
Local $sString = "((Округлвверх((((Bh_1+Bh_2+(CountBlockModule_Bh-1)*10+Bh_3)+2*168)/2/0.9954-(60+60))/1500)+1)*2*" & @CRLF & _
"((Если" & @CRLF & _
"CountBlockModule_Bh==3 и CountBlockModule_Lh==20" & @CRLF & _
"и Lh_19>2435" & @CRLF & _
"то" & @CRLF & _
"(Lh_19+8)" & @CRLF & _
"иначе 0)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")