Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(\s)?(\-)?((((\d+)|(\d{1,3})(\,\d{3})*)(\.\d{2})?)|(((\d+)|(\d{1,3})(\.\d{3})*)(\,\d{2})?))$
/
gm
Input 1
1
New
1111111111 1111111111.00 1111111111,00 1,111,111,111.00 1.111.111.111,00 -1111111111 -1111111111.00 -1111111111,00 -1,111,111,111.00 -1.111.111.111,00