package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`session_state \((?<session_state>[^\)]+)\)`)
var str = `session_state (SYN, ACK)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}