const regex = /session_state \((?<session_state>[^\)]+)\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('session_state \\((?<session_state>[^\\)]+)\\)', '')
const str = `session_state (SYN, ACK)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}