use strict;
my $str = 'user.name@domain.com';
my $regex = qr/([\w.-]+@([\w-]+)\.+\w{2,})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";