$re = '/^[^:]+:/m';
$str = 'd016eb66c977d646642d491ae8461134:12345asdf
90ef258293ee214d1128abecd7b96f99:61231afad';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;