package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{0,1}\.*[0-9]{0,3},[0-9]{2,2}$`)
var str = `102,00
103,78
1.000,34
11.000,00
11.000,10
100,10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}