const regex = /^[0-9]{0,1}\.*[0-9]{0,3},[0-9]{2,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{0,1}\\.*[0-9]{0,3},[0-9]{2,2}$', 'gm')
const str = `102,00
103,78
1.000,34
11.000,00
11.000,10
100,10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}