using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\b[^>]*\bsrc\s*=\s*(['""])(.*?)\1";
string input = @"hello, here's an <img alt=""image"" src=""some://url""/> and here's a <video src=""not://interested""/>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}