const regex = /<img\b[^>]*\bsrc\s*=\s*(['"])(.*?)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\b[^>]*\\bsrc\\s*=\\s*([\'"])(.*?)\\1', 'g')
const str = `hello, here's an <img alt="image" src="some://url"/> and here's a <video src="not://interested"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}