# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\S*\d+\S*//gm;t' <<< "אני קניתי ב2.5~ ש\"ח"