package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*\d+\S*`)
var str = `אני קניתי ב2.5~ ש"ח`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}