$re = '/\S*\d+\S*/m';
$str = 'אני קניתי ב2.5~ ש"ח';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;